WTAO Branding issue

WTAO seems to have no branding on xExchange and the farm name contains the full token name of WTAO

I doubt this is intentional can the team look into it?

It should be fixed now? This is a caching issue on xExchange side.

Hmmm for me there is still the default ESDT image instead of the TAO Logo

This is what I personally see:

Could you share a screenshot on your side?


Forgot to update you on this but this should be fixed. Thanks for having reported! :pray:

still not fixed for me

Very weird… I’ve gone through every single page of xExchange seeing the logo. On which precise page have you the issue? Could you share the URL? Also I’ve you tried to open an incognito window just to be if the issue persists also there?

Yes i tried with incognito

It’s on the farms page

If i try on a whole another device it’s the same issue!

Okay, very weird… Do you think you could DM me on Telegram?

It will be easier to continue to investigate. Thank you very much for your help and patience :pray:

I prefer not to - is there any browser side debugging i can do to help?