Impossible to swap egld to utk or ride and mex

all my swaps are still pending…

1 Like

The same issue, unable to swap, transaction faild

I have the same issue!

Hi @jeanalain @jaroslavs @curiosity

I’ve tried to swap all these tokens and it worked for him.

If the transactions failed, please share the link to the transactions on the explorer, as this will allow us to investigate.

Also, please note that the testnet is less reliable than the mainnet and could sometimes take longer to process transactions, explaining the long waiting time.

It dose not work for me still.

I’ve tried to create a dual farm and I’ve also tried to get some mex and make it xMex and I’m waiting for the transaction to go through and is saying pending until a moment in time where it just vanish from testnet explorer.

this is the hash : 5384ff361da4f8223fedb030471783eac2b33720b6c7e3747b73cdc0749403c5

maybe now you can still see it but in ~20 minsh it will not be there anymore.

edit: ~25 min pass and is still pending the tx.

second edit: after ~27 min (let’s say 30 min) the transaction vanished.


Thanks @curiosity for the report! Very unclear for me what happens and not sure it is an issue from xExchange, but will forward internally :pray:

@curiosity Could you please try doing a simple EGLD → UTK swap? To see if the issue appears in this very simple scenario.

Please try to logout and login before doing this to be sure to start from a clean state.

Let me know once you’ve done this and what’s the result.

If possible, could you please share me the address of the account for which the issue occurs.

Last, do you have the guardian feature activated?

hey @lucaswillems the result looks same ( I didn’t wait 30 min to see but looks similar like the dual pool creation)
This is the address I’m using for testnet: erd1u880d4dxudgs3quvf6prtzdqtzy5kdgxgpgqccnd6ctslt92tt8snnp2uc
and yes, I do have the guardian feature active.

Thanks! :pray: :pray:

Forwarding internally! I hope we will succeed to find the cause of this issue.

@curiosity Could you please DM me on Telegram? My handle: Telegram: Contact @LucasWillems

Will try to setup a group to discuss more easily and have some team members to help you.

Hey @curiosity , so it is an issue in xPortal.

An easy way for you to test xExchange would be to create another wallet inside of xPortal, which you will keep unguarded and for testing purposes only, and use it to test xExchange.

How does it sound?